View Issue Details

IDProjectCategoryView StatusLast Update
0000062Bacula-Webbug-phppublic2012-08-30 09:34
ReporterChCAssigned Todavide 
Status closedResolutionfixed 
Product Version5.2.6 
Target Version5.2.10Fixed in Version5.2.10 
Summary0000062: SQLite connection issue - invalid data source name

I hope you can help me this way while configuring Bacula-Web.

I have Bacula installed and set up on a Synology NAS (manual will be online soon), but it would be nice to have Bacula-Web for the reporting.
For Bacula I have a SQLite database located in /opt/local/var/bacula/working/bacula.db
The apache user has full read/write access to this folder and db.

In config.php my connection is setup as:
 // SQLite bacula catalog
  $config[0]['label'] = 'Dev backup server';
  $config[0]['db_name'] = 'sqlite:/opt/local/var/bacula/working/bacula.db';

I also tried (as in the config.php.sample):
  $config[0]['db_name'] = '/opt/local/var/bacula/working/bacula.db';

Unfortunately, when I go to the bacula-web url, or the test.php I receive the following message:
Database error
Message: invalid data source name

I noticed that there was a debug statement in de exception-handling file, how can I enable this feature? Maybe this brings me any further.

Thanks in advance.
TagsNo tags attached.



2012-07-06 12:31


config.php (1,830 bytes)


2012-07-06 12:49

reporter   ~0000115

Here is a bit more info about the device

Synology DS212j
Linux armv5tel GNU/Linux
PHP Version 5.3.10
SQLite3 3.7.13
Bacula 5.2.10

There are no messages corresponding to bacula-web in the apache-logs.


2012-07-07 10:53

manager   ~0000118


I think that I've found why it doesn't work.

Could you try with this configuration and get back to me please ?

 // SQLite bacula catalog
$config[0]['db_type'] = 'sqlite'; <--- this line is missing
$config[0]['label'] = 'Dev backup server';
$config[0]['db_name'] = 'sqlite:/opt/local/var/bacula/working/bacula.db';

In the file config.php.sample, the line with db_type is missing.
It will be updated in next version



2012-07-09 00:03

manager   ~0000119

I've made some test on my side and adding the line mentioned before fixed the problem.

The documentation have been updated as well



2012-07-09 07:36

reporter   ~0000120

Yes, this indeed solved the problem.
Unfortunately, I had some more debugging to do in order to get things working, but these were all related to rights and system dependent.


2012-08-10 11:10

manager   ~0000137

The file config.php.sample have been updated to prevent that kind of problem.



2012-08-29 21:24

reporter   ~0000151

For completeness hereby the link for the manual for Bacula on the Synology device.


2012-08-30 09:34

manager   ~0000152

Thanks for the link.

Issue History

Date Modified Username Field Change
2012-07-05 10:44 davide New Issue
2012-07-05 10:44 davide Status new => assigned
2012-07-05 10:44 davide Assigned To => davide
2012-07-06 12:31 ChC File Added: config.php
2012-07-06 12:49 ChC Note Added: 0000115
2012-07-07 10:35 davide Reporter davide => ChC
2012-07-07 10:53 davide Note Added: 0000118
2012-07-07 10:53 davide Status assigned => feedback
2012-07-09 00:03 davide Note Added: 0000119
2012-07-09 07:36 ChC Note Added: 0000120
2012-07-09 07:36 ChC Status feedback => assigned
2012-08-10 11:08 davide Fixed in Version => 5.2.10
2012-08-10 11:08 davide Target Version => 5.2.10
2012-08-10 11:10 davide Note Added: 0000137
2012-08-10 11:10 davide Status assigned => resolved
2012-08-10 11:10 davide Resolution open => fixed
2012-08-29 21:24 ChC Note Added: 0000151
2012-08-29 21:24 ChC Status resolved => feedback
2012-08-29 21:24 ChC Resolution fixed => reopened
2012-08-30 09:34 davide Note Added: 0000152
2012-08-30 09:34 davide Status feedback => closed
2012-08-30 09:34 davide Resolution reopened => fixed