View Issue Details

IDProjectCategoryView StatusLast Update
0000262Bacula-Webbug-phppublic2019-03-11 18:36
Reportermisere_beAssigned Todavide 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformbacula 5.2.13OSLinux RHOS VersionRHEL 7.X
Product Version8.0.1 
Target Version8.3.0Fixed in Version8.3.0 
Summary0000262: Biggest jobs size is total job size
DescriptionIn the dashboard, the "biggest backup jobs" have a size that is equals to the total amount of data for all the jobs with the same name.

So it does not equal the amount of data for one job, what ever the job.

 
Steps To ReproduceHow i got the issue :
* Install the 8.0.1 version on RHEL/apache.
* Connect to a bacula director 5.2.0. with a user having Read Only rights.
* Select the director, compare "client jobs total" with "Biggest backup jobs".
Additional InformationHere a screen shot with hidden backup names. Here one item is show but the problem appears for each job name.

I can do some work for the SQL request.
TagsNo tags attached.

Activities

misere_be

2018-08-23 17:20

reporter  

davide

2018-08-24 15:45

manager   ~0000841

Both widgets "Biggest backup jobs" & "Clients jobs total" seem's to display same statistics.

davide

2019-02-23 12:55

manager   ~0000955

Looks like the screenshot is gone ?!?

Can you provide it again please ?

davide

2019-02-24 13:38

manager   ~0000957

Never mind, the issue with attachment is fixed now.

davide

2019-02-24 13:59

manager   ~0000958

Hello,

Please find below the expected Bacula stats from each widget.

"Clients jobs total"
- List jobs per type with jobs, files, bytes
- Total of Files, Bytes and Jobs per type of job.

"Biggest backup jobs"
- List biggest backup job names (sum).

I agree that both widget has pretty much the same statistics.
Maybe "Biggest backup jobs" might need to point to only ONE backup job.
The job name should be "clickable" to see job details.

What do you think ?

davide

2019-03-11 18:26

manager   ~0000992

Widget fixed.

The bug fix will be included in next release

Issue History

Date Modified Username Field Change
2018-08-23 17:20 misere_be New Issue
2018-08-23 17:20 misere_be File Added: bug bacula-web max job size.png
2018-08-24 14:40 davide Assigned To => davide
2018-08-24 14:40 davide Status new => assigned
2018-08-24 15:45 davide Status assigned => confirmed
2018-08-24 15:45 davide Note Added: 0000841
2019-01-05 12:45 davide Target Version => 8.3.0
2019-02-23 12:51 davide Description Updated View Revisions
2019-02-23 12:55 davide Note Added: 0000955
2019-02-23 13:27 davide File Added: logo.png
2019-02-23 16:12 mbtadmin File Deleted: logo.png
2019-02-24 13:38 davide Note Added: 0000957
2019-02-24 13:59 davide Status confirmed => feedback
2019-02-24 13:59 davide Note Added: 0000958
2019-03-11 18:26 davide Status feedback => resolved
2019-03-11 18:26 davide Resolution open => fixed
2019-03-11 18:26 davide Fixed in Version => 8.3.0
2019-03-11 18:26 davide Note Added: 0000992
2019-03-11 18:36 davide Category bug-pgsql => bug-php