View Issue Details

IDProjectCategoryView StatusLast Update
0000261Bacula-Webbugpublic2018-09-16 10:00
ReporterapvargasAssigned Todavide 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version8.0.1 
Target VersionFixed in Version 
Summary0000261: Blank Screen when i am finishing my instalation
DescriptionHello everyone, I'm having a problem, just at the end of my installation, when the login page should be displayed, I only get a blank page with the message: run ();

How can i solve this?



Thanks in advance
TagsNo tags attached.

Activities

apvargas

2018-08-10 23:21

reporter  

davide

2018-08-16 09:28

manager   ~0000838

Hello,

Looks like PHP isn't enabled properly for the web server, please check your web server error log.

In the meantime, I've written a small PHP script which hopefully, will help me to identify source of your problem
Instructions and script are available here

https://www.bacula-web.org/download/setup-php/

Get back to me with output of the script please

apvargas

2018-08-21 17:13

reporter   ~0000839

Hi, this is the output of the script excecution:

root@bacula:/var/www/html# sudo -u www-data php setup.php
PHP Warning: include_once(core/global.inc.php): failed to open stream: No such file or directory in /var/www/html/setup.php on line 19
PHP Warning: include_once(): Failed opening 'core/global.inc.php' for inclusion (include_path='.:/usr/share/php') in /var/www/html/setup.php on line 19
Bacula-Web auth setup script

Checking requirements

Ok PHP version
Warning PHP timezone
Error Protected assets folder is writable
PHP Notice: Use of undefined constant VIEW_CACHE_DIR - assumed 'VIEW_CACHE_DIR' in /var/www/html/setup.php on line 86
Error Smarty cache folder write permission
Ok PHP Posix support
Ok PHP PDO support
Error PHP SQLite support
PDO drivers (available):
Ok PHP Gettext support
Ok PHP Session support
It's now time to setup the application back-end database

Please note that all informations stored in the user database will be destroyed
Can we proceed ?

Answer (Yes/No): Yes
Let's go !
Deleting application back-end database
Database error could not find driver code(0)root@bacula:/var/www/html#

davide

2018-08-21 17:35

manager   ~0000840

Hi,

You need to run the command from Bacula-Web folder.
This is why you got the error "Failed opening 'core/global.inc.php".

Also, you need to fix errors in the first phase (see lines starting with Error).

Hope it helps

Best regards

davide

2018-09-09 08:51

manager   ~0000844

Any update ?

davide

2018-09-16 09:59

manager   ~0000857

You need to install PHP SQLite module.

Error PHP SQLite support
Database error could not find driver code(0)root@bacula:/var/www/html# 

davide

2018-09-16 10:00

manager   ~0000858

Since I got no feedback from you since several days, I'm closing this bug report.

Feel free to reopen it if needed.

Best regards

Issue History

Date Modified Username Field Change
2018-08-10 23:21 apvargas New Issue
2018-08-10 23:21 apvargas File Added: Captura de pantalla de 2018-08-10 17-20-30.png
2018-08-16 09:25 davide Assigned To => davide
2018-08-16 09:25 davide Status new => assigned
2018-08-16 09:28 davide Status assigned => feedback
2018-08-16 09:28 davide Note Added: 0000838
2018-08-21 17:13 apvargas Note Added: 0000839
2018-08-21 17:13 apvargas Status feedback => assigned
2018-08-21 17:35 davide Note Added: 0000840
2018-09-09 08:51 davide Status assigned => feedback
2018-09-09 08:51 davide Note Added: 0000844
2018-09-16 09:59 davide Note Added: 0000857
2018-09-16 10:00 davide Status feedback => resolved
2018-09-16 10:00 davide Resolution open => no change required
2018-09-16 10:00 davide Note Added: 0000858