View Issue Details

IDProjectCategoryView StatusLast Update
0000091Bacula-Webbug-designpublic2014-11-18 13:24
ReporterChCAssigned Todavide 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Platformarmv5telOSLinuxOS Version2.6.32.12
Product Version5.2.12 
Target Version7.0.0Fixed in Version7.0.0 
Summary0000091: Visibility long volume-names
DescriptionI let bacula create new volumes for specific backups. Like Monthly or Base backups.

In the naming of these volumes, the name of the job + the date of the job is taken into account. Which leads to quite large, but understandable volume-names.

Unfortunately these long volume/job names break the layout of bacula-web. Please see attached screenshots
Steps To ReproduceUse long volume/job names in Bacula
TagsNo tags attached.

Activities

ChC

2013-02-21 11:47

reporter  

volume_view.png (15,304 bytes)
volume_view.png (15,304 bytes)

ChC

2013-02-21 11:48

reporter  

main_view.png (57,392 bytes)
main_view.png (57,392 bytes)

ChC

2013-02-21 11:54

reporter   ~0000224

Possible fix is to lose fixed column width in the volume/pool view. Or perhaps use css:min-width for each column.

for the widget in the main view; if the fixed width of 340px is changed to min-width. Then the "too large" last-volumes widget is automatically resized in Firefox and placed below the other two widgets, see image main_view_posfix.png

ChC

2013-02-21 11:54

reporter  

main_view_posfix.png (47,295 bytes)
main_view_posfix.png (47,295 bytes)

davide

2013-03-04 10:17

manager   ~0000229

Hi,

Don't worry about this, the dashboard layout is going to change in a next version.

The new dashboard should fix that kind of problem (long pools,volumes,jobs names)

Regards

davide

2013-10-15 21:28

manager   ~0000277

Hi,

I've a suggestion about the bug request you reported.

What about "truncate" very long pools/jobs/media names ?

Thanks for your feedback.

ChC

2013-10-17 15:22

reporter   ~0000278

In my case it wouldn't do, as the volume names are build up like, pool_backupname_date_backuptype.

Not having all widgets next to each-other is no problem for me, that is why I proposed the min-width option.

Want me to have a look at the new dashboard and think along with you?

davide

2013-10-19 09:48

manager   ~0000279

Hi,

let me propose this if you agree ...

I'm going to publish the next bug fix release of bw in few days but it wouldn't fix your problem (I'm working on another branch for this).

Once this dev branch is ready, I'll send you the tarball to test it on your server (you'll be the first guy testing the new layout ;) )

Does it sound good for you ?

Regards

ChC

2013-10-25 11:01

reporter   ~0000281

That would be great.
You can see my email-address right?

We have also emailed before.

davide

2014-10-07 10:05

manager   ~0000398

Hi,

Would you like to test next release (6.1.0) and see if this issue is solved ?
Sorry to come back to you that late about this.

Regards

ChC

2014-10-22 22:14

reporter   ~0000400

No problem, how can I get the 6.1.0 release?

davide

2014-10-23 08:38

manager   ~0000402

Hi,

Thanks for your feedback.

I'll get back to you within next few days with an tarball (pre-release).

Best regards

davide

2014-11-11 09:33

manager   ~0000408

Hi,

Sorry to bother you again with this but have you been able to test the archive I've sent you few days ago ?

I'm pretty ready to release next version and I need your feedback.

Thanks again for your help.

Best regards

davide

2014-11-18 13:24

manager   ~0000412

Haven't received feedback from user but I think the problem is solved (made some test on my side). If not, the bug will be reopened.

Fixed in release 7.0.0

Issue History

Date Modified Username Field Change
2013-02-21 11:47 ChC New Issue
2013-02-21 11:47 ChC File Added: volume_view.png
2013-02-21 11:48 ChC File Added: main_view.png
2013-02-21 11:54 ChC Note Added: 0000224
2013-02-21 11:54 ChC File Added: main_view_posfix.png
2013-03-04 10:17 davide Note Added: 0000229
2013-05-01 11:03 davide Assigned To => davide
2013-05-01 11:03 davide Status new => assigned
2013-10-15 21:28 davide Note Added: 0000277
2013-10-15 21:28 davide Status assigned => feedback
2013-10-17 15:22 ChC Note Added: 0000278
2013-10-17 15:22 ChC Status feedback => assigned
2013-10-19 09:48 davide Note Added: 0000279
2013-10-19 09:48 davide Status assigned => feedback
2013-10-25 11:01 ChC Note Added: 0000281
2013-10-25 11:01 ChC Status feedback => assigned
2014-09-29 16:29 davide Target Version => 7.0.0
2014-09-29 16:30 davide Product Version => 5.2.12
2014-10-07 10:05 davide Note Added: 0000398
2014-10-07 10:05 davide Status assigned => feedback
2014-10-22 22:14 ChC Note Added: 0000400
2014-10-22 22:14 ChC Status feedback => assigned
2014-10-23 08:38 davide Note Added: 0000402
2014-11-11 09:33 davide Note Added: 0000408
2014-11-11 09:33 davide Status assigned => feedback
2014-11-18 13:24 davide Note Added: 0000412
2014-11-18 13:24 davide Status feedback => resolved
2014-11-18 13:24 davide Fixed in Version => 7.0.0
2014-11-18 13:24 davide Resolution open => fixed
2014-12-24 11:36 davide Category design => bug/design
2016-04-17 15:36 davide Category bug/design => bug-design