View Issue Details

IDProjectCategoryView StatusLast Update
0000238Bacula-Webdocumentationpublic2018-03-11 11:48
ReporterwebsunAssigned Todavide 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04LTS
Product Version8.0.0-rc2 
Target Version8.0.0-rc3Fixed in Version8.0.0-rc3 
Summary0000238: Unable to install Bacula-Web using Composer
DescriptionHello, I am back. According to doc, should run composer. However, probalbly an extra argument required:

# sudo -u www-data php composer.phar require bacula-web/bacula-web
Cannot create cache directory /root/.composer/cache/repo/https---packagist.org/, or directory is not writable. Proceeding without cache
Cannot create cache directory /root/.composer/cache/files/, or directory is not writable. Proceeding without cache


  [InvalidArgumentException]
  Could not find a version of package bacula-web/bacula-web matching your minimum-stability (stable). Require it with an explicit version constraint allow
  ing its desired stability.


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...
TagsNo tags attached.

Activities

davide

2018-03-04 18:45

manager   ~0000736

The reason is that there's no "stable" version of Bacula-Web released yet.

Latest version is 8.0.0-rc2 (release candidate).

I'll investigate and try to find a solution, but in the meantime, try to use the archive.

davide

2018-03-06 08:55

manager   ~0000742

Hello,

I did some investigations and found the correct way to install Bacula-Web using Composer.

Can you test steps described here and let me know if it works for you please ?
http://bugs.bacula-web.org/view.php?id=240#c740

I'll update documentation for next version

davide

2018-03-11 11:48

manager   ~0000755

Documentation is fixed for next release candidate

Issue History

Date Modified Username Field Change
2018-03-04 10:02 websun New Issue
2018-03-04 18:33 davide Assigned To => davide
2018-03-04 18:33 davide Status new => assigned
2018-03-04 18:41 davide Category bug-php => documentation
2018-03-04 18:41 davide Summary Could not find a version of package bacula-web/bacula-web matching your minimum-stability => Unable to install Bacula-Web using Composer
2018-03-04 18:45 davide Note Added: 0000736
2018-03-06 08:55 davide Status assigned => feedback
2018-03-06 08:55 davide Note Added: 0000742
2018-03-11 11:21 davide Target Version => 8.0.0-rc3
2018-03-11 11:48 davide Status feedback => resolved
2018-03-11 11:48 davide Resolution open => fixed
2018-03-11 11:48 davide Fixed in Version => 8.0.0-rc3
2018-03-11 11:48 davide Note Added: 0000755