View Issue Details

IDProjectCategoryView StatusLast Update
0000203Bacula-Webbug-phppublic2017-03-22 18:06
ReporterolibragaAssigned Todavide 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version7.3.0 
Target Version7.4.0Fixed in Version7.4.0 
Summary0000203: Ubuntu PHP version string problem
Descriptiontest.php shows PHP fail status and description:
  "PHP must be at least version 5.3 (current version = 5.3.10-1ubuntu3.26)"
Steps To ReproduceRun test.php on Ubuntu (I expect the problem is the trailing -1ubuntu3.26 string and all/most Ubuntu package versions contain such postfixes)
Additional InformationUbuntu 12.04.5 LTS
TagsNo tags attached.

Activities

davide

2017-03-14 11:27

manager   ~0000579

I'll find a fix for Ubuntu.

Thanks for this bug report

davide

2017-03-22 16:47

manager   ~0000580

I found a typo in test.php.

It should not display
"PHP version must be at least 5.3"
but
"PHP version must be at least 5.4"

By the way, I'm gonna update the minimal PHP version to 5.6 (see link from PHP.net below)

http://php.net/supported-versions.php

davide

2017-03-22 17:54

manager   ~0000581

Fixed typo in test.php

In the next maintenance release, you'll need at least PHP 5.6 to run Bacula-Web.

Thanks for this bug report

Issue History

Date Modified Username Field Change
2017-03-14 03:37 olibraga New Issue
2017-03-14 11:26 davide Assigned To => davide
2017-03-14 11:26 davide Status new => assigned
2017-03-14 11:27 davide Status assigned => acknowledged
2017-03-14 11:27 davide Note Added: 0000579
2017-03-22 16:47 davide Note Added: 0000580
2017-03-22 17:54 davide Status acknowledged => resolved
2017-03-22 17:54 davide Resolution open => fixed
2017-03-22 17:54 davide Note Added: 0000581
2017-03-22 18:06 davide Fixed in Version => 7.4.0
2017-03-22 18:06 davide Target Version => 7.4.0