View Issue Details

IDProjectCategoryView StatusLast Update
0000190Bacula-Webbug-phppublic2016-06-22 08:21
Reporters.cornetAssigned Todavide 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version7.1.0 
Target Version7.2.0Fixed in Version7.2.0 
Summary0000190: Some backup jobs in Jobs report page shows a duration of 0 second
DescriptionSome backup jobs in Jobs report page shows a duration of zero second.

Looking at the job log, I can clearly see that the job took at least 1 second (see example below)

It looks like Jobs report page doesn't correct start + end time for jobs.

The result is that the job speed is not correct.
Steps To ReproduceDisplay Job report page
Additional Information2016-03-28 12:22:44 myhost JobId 17: shell command: run BeforeJob "/opt/bacula/scripts/make_catalog_backup.pl MyCatalog"
......
2016-03-28 12:22:45 myhost JobId 17: shell command: run AfterJob "/opt/bacula/scripts/delete_catalog_backup"
TagsNo tags attached.

Activities

davide

2016-06-22 07:44

manager   ~0000550

It looks like startdate and enddate fields does not reflect what we can see in job logs (see example below)

job details:
startdate: 2016-06-04 06:20:43
enddate: 2016-06-04 06:20:43

job log:
2016-06-04 06:20:42 myhost JobId 32: shell command: run BeforeJob "/opt/bacula/scripts/make_catalog_backup.pl MyCatalog"
.... output truncated ....
2016-06-04 06:20:43 myhost JobId 32: shell command: run AfterJob "/opt/bacula/scripts/delete_catalog_backup"

We can clearly see that the job startdate is not correct :(

davide

2016-06-22 07:48

manager   ~0000551

As it looks to be Bacula bug, I'll change elasped time to 1 second if the job is in "completed" status, files and bytes are not equal to 0

davide

2016-06-22 08:21

manager   ~0000552

Problem fixed :)

The fix will be included in next release (7.2.0)

Issue History

Date Modified Username Field Change
2016-06-18 10:27 davide New Issue
2016-06-18 10:27 davide Status new => assigned
2016-06-18 10:27 davide Assigned To => davide
2016-06-18 10:28 davide Reporter davide => s.cornet
2016-06-18 10:28 davide Description Updated View Revisions
2016-06-18 10:29 davide Additional Information Updated View Revisions
2016-06-22 07:44 davide Note Added: 0000550
2016-06-22 07:44 davide Additional Information Updated View Revisions
2016-06-22 07:48 davide Note Added: 0000551
2016-06-22 08:21 davide Note Added: 0000552
2016-06-22 08:21 davide Status assigned => resolved
2016-06-22 08:21 davide Fixed in Version => 7.2.0
2016-06-22 08:21 davide Resolution open => fixed