View Issue Details

IDProjectCategoryView StatusLast Update
0000175Bacula-Webfeaturepublic2016-04-14 08:40
ReporterwandihuttelAssigned Todavide 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version7.0.3 
Target Version7.1.0Fixed in Version7.1.0 
Summary0000175: Display total of Bytes for each Pool
DescriptionDisplay total of bytes for each pool in Pools and volumes report page
Steps To ReproduceDisplay Pools and volumes report page
TagsNo tags attached.

Relationships

related to 0000187 resolveddavide Total of bytes per pool problem in Pool and volumes report 

Activities

davide

2015-07-16 11:00

manager  

total_bytes_per_pool.png (52,915 bytes)
total_bytes_per_pool.png (52,915 bytes)

davide

2016-03-30 09:06

manager   ~0000515

This feature has been added to next Bacula-Web release (7.1.0).

Thanks a million for your great idea :)

wandihuttel

2016-04-06 12:38

reporter   ~0000527

I've just update to 7.1.0 and it looks is not working.
It showing 0 bytes in all pools.
I'm running bacula 7.4.0

davide

2016-04-07 09:51

manager   ~0000528

That's not cool :(

Can you check if you have PHP errors / warning in Apache logs please ?

wandihuttel

2016-04-07 12:43

reporter   ~0000529

I've found an error in apache log.
Undefined index: sum in /var/www/bweb/core/bweb.class.php on line 193

Then I added an alias to sum and it worked fine.
$sql = "SELECT SUM(Media.volbytes) as SUM FROM Media WHERE Media.PoolId = '" . $pool['poolid'] . "'";

davide

2016-04-07 14:24

manager   ~0000530

Thanks for your feedback, it's realy appreciated ...

I'd like to reproduce the problem in my lab so, can you tell me if you are using MySQL, postgreSQL or SQLite and which version.

Thanks a million for your help

wandihuttel

2016-04-07 14:29

reporter   ~0000531

I'm using MySQL
mysql Ver 14.14 Distrib 5.5.46, for debian-linux-gnu (x86_64) using readline 6.3

I suggest you discontinues support for SQLite because it looks Bacula will not support anymore in the future.

davide

2016-04-08 08:10

manager   ~0000532

Thanks for your feedback.
I'll fix the code and make a special minor bugfix release (7.1.1)

P.S: please note that something went wrong the 7.1.0 tar.gz, I've removed it from the website until I fix the problem.
It will be back soon.

Regards

davide

2016-04-14 08:40

manager   ~0000534

I created a new bug report for this problem and assigned you as the reporter.

http://bugs.bacula-web.org/view.php?id=187

I'll close this feature request as the feature is implemented, if you don't mind.

Let's continue chatting on the new bug report.

P.S: the 7.1.0 release tarball is back on the website ;)
As Bacula haven't clearly said that SQLite isn't supported anymore, I'm affraid I'll have to continue to support it :(

Issue History

Date Modified Username Field Change
2015-07-16 10:59 davide New Issue
2015-07-16 10:59 davide Status new => assigned
2015-07-16 10:59 davide Assigned To => davide
2015-07-16 11:00 davide File Added: total_bytes_per_pool.png
2015-07-16 14:27 davide Reporter davide => wandihuttel
2016-03-20 13:14 davide Target Version => 7.1.0
2016-03-28 13:56 davide Description Updated View Revisions
2016-03-30 09:06 davide Note Added: 0000515
2016-03-30 09:06 davide Status assigned => resolved
2016-03-30 09:06 davide Fixed in Version => 7.1.0
2016-03-30 09:06 davide Resolution open => fixed
2016-04-06 12:38 wandihuttel Note Added: 0000527
2016-04-06 12:38 wandihuttel Status resolved => feedback
2016-04-06 12:38 wandihuttel Resolution fixed => reopened
2016-04-07 09:51 davide Note Added: 0000528
2016-04-07 12:43 wandihuttel Note Added: 0000529
2016-04-07 12:43 wandihuttel Status feedback => assigned
2016-04-07 14:24 davide Note Added: 0000530
2016-04-07 14:24 davide Status assigned => feedback
2016-04-07 14:29 wandihuttel Note Added: 0000531
2016-04-07 14:29 wandihuttel Status feedback => assigned
2016-04-08 08:10 davide Note Added: 0000532
2016-04-14 08:37 davide Relationship added related to 0000187
2016-04-14 08:40 davide Note Added: 0000534
2016-04-14 08:40 davide Status assigned => closed
2016-04-14 08:40 davide Resolution reopened => fixed