View Issue Details

IDProjectCategoryView StatusLast Update
0000171Bacula-Webbug-phppublic2016-03-20 13:11
ReporterEric GriepsmaAssigned Todavide 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version7.0.2 
Target Version7.1.0Fixed in Version7.1.0 
Summary0000171: Running and Waiting jobs older than 24 hours are not visible in Dashboard
DescriptionRunning and Waiting jobs elder than 24 hours are not visible in main page if period is set to 24 hours. Technical this is incorrect as the jobs are running in the time frame.
Steps To ReproduceStart a job that takes more than 24 hours. It will not be shown in the overview if period is set to 24 hours
Additional InformationI had to fix this on two places:

in index.php:

changed :
$view->assign('running_jobs', Jobs_Model::count_Jobs($dbSql->db_link, $custom_period, 'running'));
to
$view->assign('running_jobs', Jobs_Model::count_Jobs($dbSql->db_link, array( LAST_WEEK, NOW), 'running'));

ALSO for the Waiting jobs

and for the graph I'd to make a if statement:
    foreach ($jobs_status as $status) {
        // EG $jobs_count = Jobs_Model::count_Jobs($dbSql->db_link, $custom_period, strtolower($status));
        if ( $status === 'Running' or $status === 'Waiting' ) {
                $jobs_count = Jobs_Model::count_Jobs($dbSql->db_link, array( LAST_WEEK, NOW), strtolower($status));
        } else {
                $jobs_count = Jobs_Model::count_Jobs($dbSql->db_link, $custom_period, strtolower($status));
        }
        $jobs_status_data[] = array($status, $jobs_count );
    }



TagsNo tags attached.

Activities

davide

2016-01-31 14:36

manager   ~0000502

Found a way to fix this even for people who have jobs running since more than a week.

Thanks

davide

2016-03-20 13:11

manager   ~0000506

The problem have been fixed in next release (7.1.0).

Thanks for submitting this bug report.

P.S: next version will be available really soon.

Regards

Issue History

Date Modified Username Field Change
2015-07-06 13:50 Eric Griepsma New Issue
2016-01-31 14:36 davide Note Added: 0000502
2016-01-31 14:36 davide Assigned To => davide
2016-01-31 14:36 davide Status new => acknowledged
2016-01-31 14:37 davide Target Version => 7.1.0
2016-03-20 12:56 davide Category bug/design => bug-php
2016-03-20 12:57 davide Summary Running and Waiting jobs elder than 24 hours are not visible in main page, it period is less than 24 hours => Running and Waiting jobs older than 24 hours are not visible in Dashboard
2016-03-20 13:11 davide Note Added: 0000506
2016-03-20 13:11 davide Status acknowledged => resolved
2016-03-20 13:11 davide Fixed in Version => 7.1.0
2016-03-20 13:11 davide Resolution open => fixed