View Issue Details

IDProjectCategoryView StatusLast Update
0000166Bacula-Webbugpublic2015-09-24 14:13
Reporterleomaia.ecoAssigned Todavide 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform64 bitsOSWindowsOS VersionWindows 7
Product Version7.0.2 
Target Version7.0.3Fixed in Version7.0.3 
Summary0000166: joblogs.php is showing wrong jobid
Descriptionjoblogs.php page shows information from the previous jobid selected;

Steps To Reproduce1) Reports
2) Jobs
3) Select any Job ID
4) Go back
5) Try to select another Job ID (different from the last one)
The joblogs.php does not show the jobid information properly. In this case the parameter seems to be fine however the page shows the previous jobid information. It might be something related to a session variable, because if we try to update the page a few minutes later it works fine.

Example:
http://server-ip/joblogs.php?jobid=9
Shows jobid 9 information

http://server-ip/joblogs.php?jobid=5
http://server-ip/joblogs.php?jobid=3
Shows jobid 9 information
Additional InformationReproduces at:

Chrome
IE
Firefox
TagsNo tags attached.

Relationships

related to 0000167 resolveddavide Problem enabling Smarty template cache 

Activities

davide

2015-02-13 04:58

manager   ~0000471

I'll look at the code and get back to you

shortyfr

2015-03-03 13:35

reporter   ~0000480

Doesn't seem to be linked to a session information because I have the same problem using wget (without any session header/cookie) :

wget -O - "http://xxxxx/bacula-web/joblogs.php?jobid=5" 2>/dev/null | grep travail
<dt>Id du travail</dt> <dd>5</dd>

wget -O - "http://xxxxx/bacula-web/joblogs.php?jobid=6" 2>/dev/null | grep travail
<dt>Id du travail</dt> <dd>5</dd>

ektich

2015-03-03 13:43

reporter   ~0000481

could be related to http://bugs.bacula-web.org/view.php?id=162 and http://bugs.bacula-web.org/view.php?id=167.

shortyfr

2015-03-03 14:13

reporter   ~0000482

Setting $this->caching = 0; in core/app/cview.class.php allows me to see reports for various jobs.

davide

2015-03-04 12:20

manager   ~0000483

Hi,

As you've mention, the source of the issue come from the Smarty template enabled.
I'm going to release a "short" maintenance/bug fix release quickly (hopefully before Saturday which will address this issue.

I'll update all bug reports and liknk those to the bug 0000167 that I'v created.

Thanks guys for your precious comments.

Davide

davide

2015-03-26 14:51

manager   ~0000487

Fixed in version 7.0.3

Issue History

Date Modified Username Field Change
2015-02-11 13:51 leomaia.eco New Issue
2015-02-13 04:58 davide Note Added: 0000471
2015-02-13 04:58 davide Assigned To => davide
2015-02-13 04:58 davide Status new => acknowledged
2015-02-13 04:59 davide Status acknowledged => assigned
2015-02-26 10:03 davide Target Version => 7.0.3
2015-03-03 13:35 shortyfr Note Added: 0000480
2015-03-03 13:43 ektich Note Added: 0000481
2015-03-03 14:13 shortyfr Note Added: 0000482
2015-03-04 12:20 davide Note Added: 0000483
2015-03-04 12:20 davide Relationship added related to 0000167
2015-03-26 14:51 davide Note Added: 0000487
2015-03-26 14:51 davide Status assigned => resolved
2015-03-26 14:51 davide Resolution open => fixed
2015-09-24 14:13 davide Fixed in Version => 7.0.3