View Issue Details

IDProjectCategoryView StatusLast Update
0000162Bacula-Webbugpublic2015-03-26 14:52
ReporterstrangeAssigned Todavide 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUbuntu 14.04OSUbuntu 14.04OS VersionUbuntu 14.04
Product Version7.0.2 
Target Version7.0.3Fixed in Version7.0.3 
Summary0000162: Client jobs filter does not work in Jobs report page
DescriptionWhen i apply a filter on a client for ex, not working.

Thanks for the display current catalog label
TagsNo tags attached.

Relationships

related to 0000167 resolveddavide Problem enabling Smarty template cache 

Activities

davide

2015-01-23 16:05

manager   ~0000464

Problem confirmed

davide

2015-01-29 11:20

manager   ~0000466

Updated the summary to make it more clear (for me and the community)

davide

2015-01-29 11:21

manager   ~0000467

Others filters do not work as expected too :(

ektich

2015-02-23 20:11

reporter   ~0000472

It seems like if you wait few minutes before clicking on "Apply" button filters and options do get applied. Some session issue?

ektich

2015-02-24 11:28

reporter   ~0000473

This is an effect of Template Caching from Smarty: if you set "$this->caching = 0" in core/app/cview.class.php this (and few other issues) disappear. But there might be a reason to have template caching enabled?

ektich

2015-02-24 11:31

reporter  

bugfix_162.patch (428 bytes)
diff --git a/core/app/cview.class.php b/core/app/cview.class.php
index 1b491ac..d52c445 100644
--- a/core/app/cview.class.php
+++ b/core/app/cview.class.php
@@ -31,7 +31,7 @@ class CView extends Smarty
 
         // Template caching
         $this->cache_dir = VIEW_CACHE_DIR;
-        $this->caching = 1;
+        $this->caching = 0;
         $this->cache_lifetime = 60;
 
         // Set to true for debug or dev purpose only
bugfix_162.patch (428 bytes)

davide

2015-02-26 09:36

manager   ~0000474

Last edited: 2015-02-26 09:46

View 2 revisions

Hi,

Thanks for your precious feedback.

I understand you mention in the last note but what's strange is that in the current code, the $this->caching variable is already set to 0 ?!?!?!

It looks like there's wrong with 7.0.2 tarball ... :(
I'll have a look at this today and get back to you asap.

Thanks for your help

Best regards

ektich

2015-02-26 10:38

reporter   ~0000478

Hmm. not if you look at a master branch in the github repository: https://github.com/bacula-web/bacula-web/blame/master/core/app/cview.class.php.
(or was it a wrong place to look at?!?)

Template caching probably makes sense for some of the pages ( to stop regeneration of png's on every request, for example), but even on a front page you'll have to wait for 60 seconds before you can switch from one catalog to another.

I've created a pull request in github for this change

davide

2015-02-26 11:19

manager   ~0000479

Hi,

Yes, you're in the right "place" ;)

The Github repo hasn't been "published" yet on www.bacula-web.org web site because I wanted to create a page which contain kind of guideline for developers who wants to create a pull request like your.
So from now I've no choice, I'll create the "developper page" on bacula-web.org asap and send an annouce to Bacula community.

Thanks for the PR, I'll just make sure that a specific (master) bug report exist (related to Smarty caching problem) and merge it asap.

Thanks a million for your help.

Best regards

Davide

davide

2015-03-26 14:52

manager   ~0000488

Fixed in version 7.0.3

Issue History

Date Modified Username Field Change
2015-01-23 10:58 strange New Issue
2015-01-23 16:05 davide Note Added: 0000464
2015-01-23 16:05 davide Assigned To => davide
2015-01-23 16:05 davide Status new => confirmed
2015-01-29 11:20 davide Note Added: 0000466
2015-01-29 11:20 davide Summary Filter Job reports not works => Client jobs filter does not work in Jobs report page
2015-01-29 11:21 davide Note Added: 0000467
2015-02-23 20:11 ektich Note Added: 0000472
2015-02-24 11:28 ektich Note Added: 0000473
2015-02-24 11:31 ektich File Added: bugfix_162.patch
2015-02-26 09:36 davide Note Added: 0000474
2015-02-26 09:37 davide Status confirmed => assigned
2015-02-26 09:37 davide Target Version => 7.0.3
2015-02-26 09:46 davide Note Edited: 0000474 View Revisions
2015-02-26 10:38 ektich Note Added: 0000478
2015-02-26 11:19 davide Note Added: 0000479
2015-03-04 12:20 davide Relationship added related to 0000167
2015-03-26 14:48 davide Relationship deleted related to 0000167
2015-03-26 14:48 davide Relationship added related to 0000167
2015-03-26 14:52 davide Note Added: 0000488
2015-03-26 14:52 davide Status assigned => resolved
2015-03-26 14:52 davide Fixed in Version => 7.0.3
2015-03-26 14:52 davide Resolution open => fixed