View Issue Details

IDProjectCategoryView StatusLast Update
0000160Bacula-Webbug-htmlpublic2015-01-19 10:18
ReportercpasqualiniAssigned Todavide 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version7.0.1 
Target Version7.0.2Fixed in Version7.0.2 
Summary0000160: Graphs loaded randomly (issue 146 not yet fixed)
DescriptionWith the fix on 7.0.1 the situation is better, but randomly i see the issue that not every graph loads ok.
One refresh and works ok but it seems that it is not yet totally fixed
TagsNo tags attached.

Relationships

duplicate of 0000146 resolveddavide Graphs sometimes disappear on Firefox 33.0 

Activities

davide

2015-01-12 16:28

manager   ~0000441

I confirm the problem

Although I didn't found from were the problem is coming from :(
If you've any idea ...


davide

2015-01-12 16:29

manager   ~0000442

Summary updated

davide

2015-01-13 08:33

manager   ~0000444

Hi,

Would you be able to test a pre-prelease in your environment which could potentialy fix this issue ?

Thanks for your feedback

cpasqualini

2015-01-13 12:19

reporter   ~0000445

yes, of course, i didn't tested it because i didn't found a svn/git repo but you can send me a download link and i will test it.

Take into account that in Friday I'm going on vacation until February so please send it earlier so i can give feedback on this week

Thanks!

davide

2015-01-13 14:49

manager   ~0000446

Hurrah !!! I've finaly found what the problem is ... :)

I'll send your a tgz pre-release asap to test it in your environment.

Thanks for your help.

davide

2015-01-14 16:17

manager   ~0000447

Hello,

I have been able to fix approx 60% of the problem ... There was 2 distincts problems

1. Some graphs in the dashboard were using the same filename as graphs in different pages. This has been fixed

2. Bacula-Web use PHPLot which generate graphs on server side. The problem is that if the page content (html, css, js, etc.) is rendered before the graph have been built, the graph would be empty.
The solution would be to use a "client side" graph library or another graph library (like pChart).
I've already plan to move from PHPLot for different reasons but haven't had the time to do it yet.

Meanwhile, what's the PHP version, OS (version) you're using ?

I'm going to send you an email within few minutes with a fresh tar.gz to test it in your environnment.

Thanks for your feedback and your help

Davide

cpasqualini

2015-01-14 16:25

reporter   ~0000448

on the PHPLot thing, what about a delay induced with javascript?
it's an ugly hack but it can do the job, i think


my system tt's a Standard Debian Wheezy

root@bacula:~# dpkg-query -l|grep php
ii libapache2-mod-php5 5.4.36-0+deb7u3 amd64 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5-cli 5.4.36-0+deb7u3 amd64 command-line interpreter for the php5 scripting language
ii php5-common 5.4.36-0+deb7u3 amd64 Common files for packages built from the php5 source
ii php5-gd 5.4.36-0+deb7u3 amd64 GD module for php5
ii php5-mysql 5.4.36-0+deb7u3 amd64 MySQL module for php5

root@bacula:~# uname -a
Linux bacula 3.2.0-4-amd64 0000001 SMP Debian 3.2.60-1+deb7u3 x86_64 GNU/Linux

i'll be waiting for your tgz

davide

2015-01-14 16:33

manager   ~0000449

Here it is ...

I've attached the archive to this bug.

Thanks for your help

cpasqualini

2015-01-14 17:03

reporter   ~0000450

in a simple test (i'm finishing my workday), it seems to not fix the problem i see...

it seems that i am been hit by the PHPLot problem
I see that one of the files is bacula-web/application/view/cache/dashboard-graph01.jpg

may be you can control/delay the output of PHP until those files are generated
i think that nobody will be hurt for a few miliseconds delay if this generates a polished user interface.

Thanks

davide

2015-01-14 17:20

manager   ~0000451

Last edited: 2015-01-14 17:29

View 2 revisions

I'll test the fix you've proposed then get back to you to test another pre-release.

Thanks for your feedback and your help.

cpasqualini

2015-01-15 14:59

reporter   ~0000452

indeed, the pre-release version works 'worst' than 7.0.1 did...
(i have re-cheked installing back and forth before reporting this)

davide

2015-01-16 09:28

manager   ~0000453

Thanks for your feedback.

I'm currently working to fix this issue definitivly then I'll send you another tar.gz archive to test.

Thanks for your help and your valuable suggestion.

davide

2015-01-16 14:31

manager   ~0000454

Last edited: 2015-01-16 14:41

View 2 revisions

I've managed to fix definitively this issue by using your recommendation (delay graphs display with javascript).

I'm not sure you're already in vacations or not but, are you able to test the new "pre release" ?

I'll attach a new tarball to this bug within few minutes.

P.S: don't worry about javascript warning/errors, this archive will come from a git branch which have to be merged in the master (it miss some important commits but it work fine for the graph bugfix purpose)

cpasqualini

2015-01-16 15:29

reporter   ~0000455

ok, I have 1 1/2 hours of work yet... then search for me in some beach in brasil ;-)

davide

2015-01-16 15:43

manager  

bacula-web-pre-release.tgz (998,354 bytes)

davide

2015-01-16 16:10

manager   ~0000457

Funny :D

Here it is ... I've attached the new tar.gz.

Thanks for your feedback

cpasqualini

2015-01-16 16:44

reporter   ~0000458

it seems to work ok, ill see you on febraury!

davide

2015-01-19 10:18

manager   ~0000460

Fixed in release 7.0.2

Issue History

Date Modified Username Field Change
2015-01-12 11:29 cpasqualini New Issue
2015-01-12 16:25 davide Assigned To => davide
2015-01-12 16:25 davide Status new => assigned
2015-01-12 16:28 davide Note Added: 0000441
2015-01-12 16:28 davide Target Version => 7.0.2
2015-01-12 16:29 davide Note Added: 0000442
2015-01-12 16:29 davide Summary issue 146 not yet fixed => Graphs loaded randomly (issue 146 not yet fixed)
2015-01-12 16:30 davide Relationship added duplicate of 0000146
2015-01-13 08:33 davide Note Added: 0000444
2015-01-13 08:33 davide Status assigned => feedback
2015-01-13 12:19 cpasqualini Note Added: 0000445
2015-01-13 12:19 cpasqualini Status feedback => assigned
2015-01-13 14:49 davide Note Added: 0000446
2015-01-14 16:17 davide Note Added: 0000447
2015-01-14 16:17 davide Status assigned => feedback
2015-01-14 16:25 cpasqualini Note Added: 0000448
2015-01-14 16:25 cpasqualini Status feedback => assigned
2015-01-14 16:31 davide File Added: bacula-web-pre-release.tgz
2015-01-14 16:33 davide Note Added: 0000449
2015-01-14 16:33 davide Status assigned => feedback
2015-01-14 17:03 cpasqualini Note Added: 0000450
2015-01-14 17:03 cpasqualini Status feedback => assigned
2015-01-14 17:20 davide Note Added: 0000451
2015-01-14 17:29 davide Note Edited: 0000451 View Revisions
2015-01-15 14:59 cpasqualini Note Added: 0000452
2015-01-16 09:28 davide Note Added: 0000453
2015-01-16 14:29 davide File Deleted: bacula-web-pre-release.tgz
2015-01-16 14:31 davide Note Added: 0000454
2015-01-16 14:31 davide Status assigned => feedback
2015-01-16 14:41 davide Note Edited: 0000454 View Revisions
2015-01-16 15:29 cpasqualini Note Added: 0000455
2015-01-16 15:29 cpasqualini Status feedback => assigned
2015-01-16 15:43 davide File Added: bacula-web-pre-release.tgz
2015-01-16 16:10 davide Note Added: 0000457
2015-01-16 16:10 davide Status assigned => feedback
2015-01-16 16:44 cpasqualini Note Added: 0000458
2015-01-16 16:44 cpasqualini Status feedback => assigned
2015-01-19 10:18 davide Note Added: 0000460
2015-01-19 10:18 davide Status assigned => resolved
2015-01-19 10:18 davide Fixed in Version => 7.0.2
2015-01-19 10:18 davide Resolution open => fixed